import re
regex = re.compile(r"(?i)lines?(?:\s+items?)?\s*\d+(?:\.\d+)?(?:\s*(?:,|and)\s*\d+(?:\.\d+)?)*", flags=re.MULTILINE)
test_str = ("Line 145\n"
"Line3544354\n"
"Lines 10,12\n"
"Line items 45,10,26\n"
"Lines 10 and 45\n\n"
"Lines 10.5666,12.566\n"
"Line 96.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")