using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?://)[^/]+/\w/\w{32}/\d+/";
string substitution = @"$1books.site/";
string input = @"https://book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/01.mp3
https://s1.book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/02.mp3
https://books.site/38904/1/01.mp3
https://books.site/38904/1/02.mp3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}