import Foundation
let pattern = #"(https?://)[^/]+/\w/\w{32}/\d+/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/01.mp3
https://s1.book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/02.mp3
https://books.site/38904/1/01.mp3
https://books.site/38904/1/02.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1books.site/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)