$re = '~(https?://)[^/]+/\w/\w{32}/\d+/~m';
$str = 'https://book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/01.mp3
https://s1.book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/02.mp3
https://books.site/38904/1/01.mp3
https://books.site/38904/1/02.mp3';
$subst = "$1books.site/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;