use strict;
my $str = 'bj-11_2008-06_2015(F01,F02,F03,F04)
bj-11_2008-06_2015(F01)
bj-11_2008-06_2015(01)
bj-11_2008-06_2015(3B)
bj-11_2008-06_2015
bj-11_2008';
my $regex = qr/bj-([0-9]{2})_([0-9]{4})[-]*([0-9]{2})?_?([0-9]{4})?([(]([[:alnum:]]{0,4},?)*[)])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}