$re = '/bj-([0-9]{2})_([0-9]{4})[-]*([0-9]{2})?_?([0-9]{4})?([(]([[:alnum:]]{0,4},?)*[)])?/m';
$str = 'bj-11_2008-06_2015(F01,F02,F03,F04)
bj-11_2008-06_2015(F01)
bj-11_2008-06_2015(01)
bj-11_2008-06_2015(3B)
bj-11_2008-06_2015
bj-11_2008';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);