using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*href='(.*)'.*</a>";
string input = @"<h1 class='blablabla'><a class='Title' href='https://www.url.com' rel='rel'>blablabla</a></h1>
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}