re = /<a.*href='(.*)'.*<\/a>/
str = '<h1 class=\'blablabla\'><a class=\'Title\' href=\'https://www.url.com\' rel=\'rel\'>blablabla</a></h1>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end