package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sU)<a.*href='(.*)'.*</a>`)
var str = `<h1 class='blablabla'><a class='Title' href='https://www.url.com' rel='rel'>blablabla</a></h1>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}