$re = '@<a.*href=\'(.*)\'.*</a>@sU';
$str = '<h1 class=\'blablabla\'><a class=\'Title\' href=\'https://www.url.com\' rel=\'rel\'>blablabla</a></h1>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);