# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img\s.*?)(src=\".+?\")(.*?\/>)/\1\2>/gm;t' <<< "<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>
<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>
<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>
<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure><figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>
"