re = /(<img\s.*?)(src=\".+?\")(.*?\/>)/m
str = '<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure><figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
'
subst = '\\1\\2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result