use strict;
my $str = '<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
<figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure><figure class="image"><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></figure>
';
my $regex = qr/(<img\s.*?)(src=\".+?\")(.*?/>)/mp;
my $subst = '\\1\\2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";