import re
regex = re.compile(r"(<img\s.*?)(src=\".+?\")(.*?/>)", flags=re.MULTILINE)
test_str = ("<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>\n"
"<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>\n"
"<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>\n"
"<figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure><figure class=\"image\"><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></figure>\n")
subst = "\\1\\2>"
result = regex.sub(subst, test_str)
if result:
print(result)