using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\s-]*(?:\d[\s*-]*){4}$";
string input = @"- 3 --- 1 2---4- -
- 3 --- 12---4- -
- 3 --- 1 2---- -
- 3 --- 1- 2---4- 5-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}