package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s-]*(?:\d[\s*-]*){4}$`)
var str = `- 3 --- 1 2---4- -
- 3 --- 12---4- -
- 3 --- 1 2---- -
- 3 --- 1- 2---4- 5-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}