$re = '/^[\s-]*(?:\d[\s*-]*){4}$/m';
$str = '- 3 --- 1 2---4- -
- 3 --- 12---4- -
- 3 --- 1 2---- -
- 3 --- 1- 2---4- 5-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);