#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(..\..).+\n(?<!not )undefined.+"
Local $sString = "datetime,n_dayAVG,n_nightAVG" & @CRLF & _
"2021-02-13T23:00:00Z,0,38.75689941512687" & @CRLF & _
"2021-02-14T06:00:00Z,42.928258741926456,39.480753102759024" & @CRLF & _
"2021-02-15T06:00:00Z,43.75857849703471,39.9099923987705" & @CRLF & _
"2021-02-16T06:00:00Z,40.64147976311876,39.62856460216651" & @CRLF & _
"2021-02-17T06:00:00Z,43.01380733014874,39.58893298143956" & @CRLF & _
"undefined,0,0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")