import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(..\\..).+\\n(?<!not )undefined.+";
final String string = "datetime,n_dayAVG,n_nightAVG\n"
+ "2021-02-13T23:00:00Z,0,38.75689941512687\n"
+ "2021-02-14T06:00:00Z,42.928258741926456,39.480753102759024\n"
+ "2021-02-15T06:00:00Z,43.75857849703471,39.9099923987705\n"
+ "2021-02-16T06:00:00Z,40.64147976311876,39.62856460216651\n"
+ "2021-02-17T06:00:00Z,43.01380733014874,39.58893298143956\n"
+ "undefined,0,0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}