re = /(..\..).+\n(?<!not )undefined.+/
str = 'datetime,n_dayAVG,n_nightAVG
2021-02-13T23:00:00Z,0,38.75689941512687
2021-02-14T06:00:00Z,42.928258741926456,39.480753102759024
2021-02-15T06:00:00Z,43.75857849703471,39.9099923987705
2021-02-16T06:00:00Z,40.64147976311876,39.62856460216651
2021-02-17T06:00:00Z,43.01380733014874,39.58893298143956
undefined,0,0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end