package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[textarea][^]*\[\/textarea])|<`)
var str = `[textarea]Content showing raw [b]HTML[/b] or any other code
Including line breaks </a>[/textarea]
<
<`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}