const regex = /(\[textarea][^]*\[\/textarea])|</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[textarea][^]*\\[\\\/textarea])|<', 'gm')
const str = `[textarea]Content showing raw [b]HTML[/b] or any other code
Including line breaks </a>[/textarea]
<
<`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}