re = /(\[textarea][^]*\[\/textarea])|</m
str = '[textarea]Content showing raw [b]HTML[/b] or any other code
Including line breaks </a>[/textarea]
<
<'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end