$re = '/(\[textarea][^]*\[\/textarea])|</m';
$str = '[textarea]Content showing raw [b]HTML[/b] or any other code
Including line breaks </a>[/textarea]
<
<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);