const regex = /(?i)(?<code>[A-Z_]{10})?_?(?<seq>[0-9]{2})?\.[A-Z]{3}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<code>[A-Z_]{10})?_?(?<seq>[0-9]{2})?\\.[A-Z]{3}$', 'g')
const str = `ABLU_TE_BO_03.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}