// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?<code>[A-Z_]{10})?_?(?<seq>[0-9]{2})?\.[A-Z]{3}$").unwrap();
let string = "ABLU_TE_BO_03.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}