$re = '/(?i)(?<code>[A-Z_]{10})?_?(?<seq>[0-9]{2})?\.[A-Z]{3}$/';
$str = 'ABLU_TE_BO_03.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);