#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*a.*b.*c.*$"
Local $sString = "aback" & @CRLF & _
"abase" & @CRLF & _
"abate" & @CRLF & _
"agateallay" & @CRLF & _
"ab" & @CRLF & _
"abcasfasdf" & @CRLF & _
"ab" & @CRLF & _
"acbasdfasdfabc" & @CRLF & _
"pqr" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")