import re
regex = re.compile(r"^.*a.*b.*c.*$", flags=re.MULTILINE)
test_str = ("aback\n"
"abase\n"
"abate\n"
"agateallay\n"
"ab\n"
"abcasfasdf\n"
"ab\n"
"acbasdfasdfabc\n"
"pqr\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")