package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*a.*b.*c.*$`)
var str = `aback
abase
abate
agateallay
ab
abcasfasdf
ab
acbasdfasdfabc
pqr
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}