re = /^.*a.*b.*c.*$/m
str = 'aback
abase
abate
agateallay
ab
abcasfasdf
ab
acbasdfasdfabc
pqr
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end