# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-----Message d'origine-----.*(?:\r?\n(?!\r?\n).*)*\s*//gm;t' <<< "Something above
-----Message d'origine-----
De : Myself <myself@himself.com>
Envoyé : vendredi 8 mars 2019 14:30
À : Someone <someone@himself.com>
Cc : AnotherGuy <another@himself.com>
Objet : My bad I forgot how to do it
Hi,
blabla"