using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-----Message d'origine-----.*(?:\r?\n(?!\r?\n).*)*\s*";
string substitution = @"";
string input = @"Something above
-----Message d'origine-----
De : Myself <myself@himself.com>
Envoyé : vendredi 8 mars 2019 14:30
À : Someone <someone@himself.com>
Cc : AnotherGuy <another@himself.com>
Objet : My bad I forgot how to do it
Hi,
blabla";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}