#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^\s*)print_debug"
Local $sString = "print_debug('scroll set: '+str(position));" & @CRLF & _
"print_debug('scroll set: '+str(position));" & @CRLF & _
" print_debug('scroll set: '+str(position));" & @CRLF & _
" print_debug('supposed current scroll: '+str(view.viewport_position())); # THIS LIES" & @CRLF & _
" else:" & @CRLF & _
" print_debug('SKIPPED...')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")