re = /(?=^\s*)print_debug/m
str = 'print_debug(\'scroll set: \'+str(position));
print_debug(\'scroll set: \'+str(position));
print_debug(\'scroll set: \'+str(position));
print_debug(\'supposed current scroll: \'+str(view.viewport_position())); # THIS LIES
else:
print_debug(\'SKIPPED...\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end