$re = '/(?=^\s*)print_debug/m';
$str = 'print_debug(\'scroll set: \'+str(position));
print_debug(\'scroll set: \'+str(position));
print_debug(\'scroll set: \'+str(position));
print_debug(\'supposed current scroll: \'+str(view.viewport_position())); # THIS LIES
else:
print_debug(\'SKIPPED...\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);