import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^\\s*)print_debug";
final String string = "print_debug('scroll set: '+str(position));\n"
+ "print_debug('scroll set: '+str(position));\n"
+ " print_debug('scroll set: '+str(position));\n"
+ " print_debug('supposed current scroll: '+str(view.viewport_position())); # THIS LIES\n"
+ " else:\n"
+ " print_debug('SKIPPED...')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}