#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^|[a-zA-z]+\w*+[\/(]*+[0-9][0-9][)]*|^"
Local $sString = "gl23455/10" & @CRLF & _
"fhgg666(01)" & @CRLF & _
"BGL25MON8/04" & @CRLF & _
"0752200036(00)" & @CRLF & _
"SGI55M04EU/70" & @CRLF & _
"KSK38422FF/01" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")