// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^|[a-zA-z]+\w*+[\/(]*+[0-9][0-9][)]*|^").unwrap();
let string = "gl23455/10
fhgg666(01)
BGL25MON8/04
0752200036(00)
SGI55M04EU/70
KSK38422FF/01
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}