using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*? - ){2}(.*)$";
string input = @"info - Name non-constant identifiers using lowerCamelCase - lib\util\constants.dart:9:25 - non_constant_identifier_names ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}