package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*? - ){2}(.*)$`)
var str = `info - Name non-constant identifiers using lowerCamelCase - lib\util\constants.dart:9:25 - non_constant_identifier_names `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}