re = /^(?:.*? - ){2}(.*)$/m
str = 'info - Name non-constant identifiers using lowerCamelCase - lib\\util\\constants.dart:9:25 - non_constant_identifier_names '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end