$re = '/^(?:.*? - ){2}(.*)$/m';
$str = 'info - Name non-constant identifiers using lowerCamelCase - lib\\util\\constants.dart:9:25 - non_constant_identifier_names ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);