$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)[A-Za-z\d!$%@#£€*?&]{8,}$/m';
$str = 'A88888jf
Aa88888jf
Aa888jf
AAAAAAAAAAA
aaaaaaaaaaaaaa
2222222222222222
1sAdfe44
$#fd#######
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);