re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)[A-Za-z\d!$%@#£€*?&]{8,}$/m
str = 'A88888jf
Aa88888jf
Aa888jf
AAAAAAAAAAA
aaaaaaaaaaaaaa
2222222222222222
1sAdfe44
$#fd#######
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end