# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(nazwa.*rozmiar\n)([\s\w\n]*)([-]{26})/$2/gm;t' <<< "nazwa plik rozmiar
progra exe 3560k
obraz gif 500k
obraz1 gif 500k
obraz2 gif 1500k
obraz3 gif 2500k
obraz4 gif 3500k
tekst txt 20k
--------------------------"