// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(nazwa.*rozmiar\n)([\s\w\n]*)([-]{26})").unwrap();
let string = "nazwa plik rozmiar
progra exe 3560k
obraz gif 500k
obraz1 gif 500k
obraz2 gif 1500k
obraz3 gif 2500k
obraz4 gif 3500k
tekst txt 20k
--------------------------";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}