const regex = /(nazwa.*rozmiar\n)([\s\w\n]*)([-]{26})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(nazwa.*rozmiar\\n)([\\s\\w\\n]*)([-]{26})', 'gm')
const str = `nazwa plik rozmiar
progra exe 3560k
obraz gif 500k
obraz1 gif 500k
obraz2 gif 1500k
obraz3 gif 2500k
obraz4 gif 3500k
tekst txt 20k
--------------------------`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);