$re = '/(nazwa.*rozmiar\n)([\s\w\n]*)([-]{26})/m';
$str = 'nazwa plik rozmiar
progra exe 3560k
obraz gif 500k
obraz1 gif 500k
obraz2 gif 1500k
obraz3 gif 2500k
obraz4 gif 3500k
tekst txt 20k
--------------------------';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;