using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^config\s.*?(?=(?:\r?\n)+(?:config\s|\Z))";
string input = @"config vdom
edit root
next
edit test
next
edit test2
next
end
config global
...
...
...
end
end
config vdom
edit root
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test2
config system
...
end
config ...
...
...
...
end
end
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}